Kyno is now owned by Signiant, Inc. Signiant’s EULA for Kyno will apply to new licenses as well as to Kyno support services and updates that we may provide. In addition, Signiant’s global privacy policy will apply in each case where Signiant’s EULA for Kyno applies, as well as to any communications with us about Kyno. Read the full announcement.
Start a new topic

Screen display problems with Kyno 1.8


I just downloaded Kyno 1.8 Trial to see how well it will work for my workflow with Resolve 16.2.x.

I have a newly built PC with the following specs:

AMD R9-3950x

Gigabyte Aorus GTX 1080Ti (running the latest NVIDIA drivers (442.92))


ASUS Crosshair VIII

2TB M.2 NVME Gen 4 SSD (Boot)

2TB (RAID 0, 4x500GB SSD) (video editing)

Dual Dell u2413 1920x1200 SDR monitors (calibrated)

I am testing the software on one of my daughter's soccer games. 

The first time I tried skimming through the first of 4 total videos it played back OK.  However, when I tried to actually create a sub-clip with in/out points and add metadata, the "screen" redraws began to get messed up. The Metadata, Content, Subclips, Tracks tabs "duplicated/overlapped" themselves.  In addition, the entire area below the video playback (excepting the time code, which was also duplicated/overlapped) turned into a solid, if irregular, white block (over the area where the File, Size, Modified, Created, etc. information is displayed).

I closed the application and tried again.  I was able to get most of the way through setting the in/out points and added the metadata, but by the time I finished with the first sub-clip and metadata, the area under the Devices (the area where drive/folder tree is displayed) had duplicated itself over the area that was white the previous time.

I do not have any similar problems with any other applications I use, including browser, Resolve, a couple games, etc., apps that I would expect to demonstrate problems if this were hardware (e.g. memory, video cards, etc.).  I currently have about 16GB RAM in use and about 46GB free.  Kyno is using just under 2GB of RAM.

I have been a formal beta tester for a number of applications in the past and this feels like that.  Is 1.8 not a full release?

I have attached an example of the screen redraw problem.  In this case, I was able to create sub-clips through about 26 min of video (the end of the first clip) and when I clicked on the "4 squares" icon to view all of the associated media in this sub-directory, you can see what happened.

The only way I know of to "fix" the problem is to close Kyno and restart it.

Is anyone else having similar problems?


1 person has this problem

I’m a paid pro user, I have submitted a ticket and emailed. No responses. About this or another separate issue I have encountered.
What link did you use for the trial of CATDV? I'm willing to try installing that to see if it will fix the problem for me with KYNO! Scott
@Randy Eckman - A lot of Java developer will use Java for the UI and C/C++ (and libraries) for the number crunchy stuff since C/C++ is more efficient with that kind of stuff (this would include video playback, transcoding, etc). So while it is possible that there are some MS C/C++ library dependencies that are causing the problem with my system (it is bad form to NOT automatically include the MS .NET library as part of your install it you are using them), it is also possible that there are Java problems as well. Sigh! Scott

goto   install CatDV Pro 13.0.12.exe  see if it works, its a demo and legit software so not a scam.  i do not recall rebooting nor opening catdv after install.

eager to hear if it does anything for you, it did on my machine.

after working with kyno, its helpful as another offload tool and tagger, but for me it looks like i need a full library mam like catdv.  I'll probably just upgrade my key for that.

if this can work correctly i could see using it but not for this price nor support response.  it seems to sit in the middle of offloader and MAM library.  for me i need a library that i can sling a bunch of clips into a bin or seq to send off to edit.  this is halfway there.


1 person likes this

@LAMAR I did so and unfortunately it didn't fix the issue for me. Wish an official fix from the now-ironically-named Lesspain Software could come after months of this persistent issue breaking our workflow. Been a paying customer of Kyno since it came out and have purchased multiple seats - it's disappointing to say the least to be left high-and-dry now. The second a comparable competitor is available with stronger support, I'm done.

1 person likes this

@LAMAR - Like David, I tried installing the CATDV software.  However, when I went to install the latest trial of Kyno, it told me my trial had expired (after only about 5 uses since the UI was unusable (see OP)).  From what I can see, I have to wait until the next "point" release (1.9 or 2.0) before I will be able to do another trial use.  Even then, "Lesspain" Software's installer says that I'll only get a week to try the update then.  UGH!

This is really frustrating with the problems I've had. It has been 4 months since my OP and I still never really got a chance to "trial" Kyno during the first 40 days.  Now my best hope is another 7 days, assuming there are no problems with the next update.  Double UGH!

At this point, this is becoming almost a comedy of errors.  Kyno still looks like the best option for me as a Resolve user (CATDV appears to only be integrated with Final Cut and Premiere).  Especially since my primary use case is for creating sub-clips.  However, since I have CATDV installed now, I guess I'll play with it until I can "trial" Kyno again.  Sigh!

Oh, I also noticed during the CATDV install that it installs a particular version of JAVA SE.  Combined with your success with running Kyno after installing CATDV, my guess is that the display problems are related to JAVA.  I keep my JAVA install updated whenever I'm notified of an update, but that didn't stop the problems with Kyno.

I'm a big fan of JAVA (at least conceptually), but it never seems to have lived up to its promise (I've been following JAVA since the late 1990s).  IF Kyno HAS used JAVA for the UI, I hope they will switch to a Mac/Windows compatible version of C/C++ so that they can have a more reliable UI.

Anyway, my $.02... for now.


Yeah I saw that too but I had a valid Java implementation installed before. Cat DV will export the same way kyno does for resolve. You just select your clips or sequence of clips that you've collected and export a XML that links or an XML with clip media. Import into resolve, it's the same thing you just have to import it they don't have a send-to direct connection preset. From the silence over months on this issue I can't support spending money on it I'll just upgrade my cat DV for 250 bucks and have a better product with real-time support. Cheers

Has anyone heard of when LessPain (LESSpain?, ouch!) might be coming out with an update?  When was the last time they released a bug fix version (I'm seeing a lot of bugs being reported)?

I would REALLY, REALLY like to try/buy this software.  However, without a bug fix for the crippling bug (on my system) I described in my original post, I simply CANNOT justify paying for software that doesn't work!

Please, LessPain, give me a reason to buy.  My credit card is ready, but your software is not.

Also, I would STRONGLY recommend you change your trial use practices!  I cannot even try the software to see if it has been fixed because I have to wait for the next "point release" and then can only get a 5 day trial period to test it and verify it is working properly, something that cannot be done in just 5 days.

AND you should allow a new 30 day trial period with every point release!  That is just a no-brainer.

If you need a justification for this, separate the trial periods by one month.  No scam users would be willing to only be able to use the software every other month.  Maybe limit it to three times between point releases?  Or add a increasing time delay screen after the original 30-day trial (between point releases) so that users could "check in" with bug fix updates to see if their issue has been resolved?

Anyway, my $.02 and I REALLY hope you will fix this bug so I can verify it works AND give you my money!


Well I made it work enough to determine that it's pretty light in features and even lighter in support it's clear that in whatever the 8 months since I've tested it and posted and sent emails to receive nothing from them it's clearly a dead product so don't worry about it go buy catDV your money will be well spent and you'll have an Enterprise level library that goes way beyond this simple unsupported offload tool. I'd actually forgotten about this program until I got an email about this issue.

We've had another report regarding the redraw issues on Windows and the user was able to isolate a software called "Riva Tuner Statistics Server" that comes bundled with "MSI Afterburner" as the cause. If any of you experiencing this issue have the software installed it'd be great to know. Possible that there are different causes for the problem but it may be worth checking.

I've checked and do not have MSI Afterburner installed on my system. I do have Ryzen Master and Aorus Engine software installed. I just uninstalled them both. After rebooting, it does seem to make some difference. However, instead of the problems appearing immediately, I am able to create 3-4 subclips before the screen redrawing problem arises. Both Afterburner and the Aorus Engine are both tweaking software for Nvidia graphics cards... that are supplied by the card manufacturers and are included in the box (at least it was with my 1080ti). Perhaps that is a common thread between the two. That said, I'm still having the screen redraw problem, even after uninstalling the above software. I can't use the software, as is. (Note: I am using v1.8.1 of the software.) Anyway, while that did appear to help a bit, it did not resolve the problem. I stand by my recommendation to change from a Java based UI to one based on another language, like C/C++. I'm going to try uninstalling all versions of Java and do the install Ashwin to see if that makes a difference. I don't use much anymore and will see if a fresh install helps. Scott

I've checked and I do not have either of those installed on mine. 

Thank you for your feedback and for digging in, sorry it didn't help. Do the redraw issues begin even if you haven't opened the player? I.e. after you start/restart Kyno and without going into any detail view with the video player? Asking because the player is the place where we have our own GPU code. If it happens before the player it must be the GPU code of the UI platform we're building onto.

Thomas, we are experiencing the same problem here. Complete graphical mess on some computers. To answer your question: It starts only after going to the video player tab. Is there any solution to this until now?

Update for everyone still having problems: We found Sonic Studio and Sonic Radar to be (paritally) responsible for the graphic mess in Kyno. After uninstalling this software (that comes along with ASUS mainboards), Kyno runs without the graphic errors. Hope that helps and hopefully there will be bugfixes and support of Kyno in the future.

Login or Signup to post a comment