Kyno is now owned by Signiant, Inc. Signiant’s EULA for Kyno will apply to new licenses as well as to Kyno support services and updates that we may provide. In addition, Signiant’s global privacy policy will apply in each case where Signiant’s EULA for Kyno applies, as well as to any communications with us about Kyno. Read the full announcement.
Start a new topic

Send to Premiere stopped working

Have any of you noticed the "send to Premeire" function stop working recently?  I did a Win 10 upgrade recently and it seems that feature was killed.  The other main variable is that footage is on a shared storage system.  Is there any reason that could effect the import function?  


Hi John, Which Version of Windows are you running exactly? We just tried on our end with Windows 10 Pro 20H2, build 19042.928, experience 120.2212.551.0. Adobe Premiere Version 15.1.0 (Build 48). It works as expected.. having files on shared storage shouldn't affect the send-to menu, does it work for local files? So the send-to Premiere menu item just doesn't show up? Maybe it would help if you sent us a feedback report from within the app under Help - Send Kyno Feedback... This will send us your log files and may contain hints to the problem.

The computer is on the exact same Windows build except it is the Home version.  However today, that system went a step further and is now caught in the "quit and clear cache" loop.  The program was performing super slow this morning so I went to change the cache location and now it simply will not open past that error pop up.  I did an uninstall and re-install and it still pops up.  I am sending you a .zip of the log via email.  

I'm having the same issue on Mac. I just updated to the latest version of premiere pro (22.0.0) and now Premiere pro no long appears and an option in the "send to" drop down. 


How do I fix this?

Send to Premiere on my Mac is not in the menu. 

I am in Big Sur 11.6.1 and Premiere 22


Does anyone have a fix yet?

Same here. "Send to Premiere" on my Mac is no longer in the menu. Only "Send to Final Cut Pro X" is displayed. 


I am in Catalina 10.15.7 and Premiere 22. 


Some other users on another discussion thread suspected that Kyno had been abandoned now that it's been bought by Signiant. Hope that's wrong, it's a great product. 

We're aware of the issue with Premiere 22 on MacOS and are working on a fix


2 people like this

Any rough estimate when the fixes and update will be released? -Thanks!

Great, thanks for update Thomas!

I'm keen for a fix!

I am creating subclips and using Command-U on my Mac to keep working. It's not as good as the "Send to Premiere Pro" function.

Login or Signup to post a comment